2010年7月7日 星期三

Oracle_System.Data.OracleClient 需有 Oracle 用戶端軟體版本 8.1.7 或以上版本

好!裝機來到Oracle,開啟網頁!登登登登!錯誤訊息一個。

ErrorMessage:System.Data.OracleClient 需有 Oracle 用戶端軟體版本 8.1.7 或以上版本
看起來這個訊息是一個跟OracleClient有關的錯誤,所以首先要先確認OracleClient是否有安裝。如果沒有安裝,手邊也沒有準備,就趕快到Oracle官網下載吧。

安裝完成後,會發現錯誤還是一模一樣,综合網路上的說法,應該是因為程式沒有權限去讀取OracleClient的相關檔案,所以我們必須將安裝的OracleClient設定權限。

方法:
1. 找到安裝資料夾,如果沒有進行變更了話,他應該會在一個類似:C:/app/Administrator/product/11.1.0的資料夾內有一個client_1。

2. 將NETWORK SERVICE使用者加入該資料夾權限內。


3. 重新啟動電腦。

最重要的一點就是要重新啟動電腦,或許重新啟動服務也OK。

這時候,理論上.....錯誤訊息就變成下一種了。 XD

沒有留言:

張貼留言